NC Angler Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
hey folks left early this morning for some fine fishig at harkers island. started to worry alittle when we got to wildlife ramp and we were the first boat there, but still was ready to catch a trout or two three ,got another bad felling when we rounded the point and there was only two boats on the rock jetty. it only got worse the motor started over heating. we tried it untill lunch with no strikes. oh well it was still a beautfull day to fish. not giveing up yet, try later:)
 

·
Red X Angler
Joined
·
16,054 Posts
Sorry it wasnt a great day. Might have a stuck thermostat from sitting dry. Or could have ripped a dry impeller in the waterpump if the boat has sat long. Was it circulating at all or could you tell?
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #7 ·
sundrop the motor had just had its 200 hour service, including a new impler installed. we took it back to the dealer when we got home. got it back today, the plate over the impeler got bent and wouldn't seal when ideling. great work by the dealer no charge.......
 

·
Red X Angler
Joined
·
16,054 Posts
Glad it was a freebie, sorry it messed up the day!
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #10 ·
I guess your're never to old to learn. from now on after haveing the engine serviced you should have a shake down run. atleast we got in a half days fishing......... tight lines
 

·
Red X Angler
Joined
·
16,054 Posts
My boat had been parked a few months. I didnt even unstrap it from the trailer until I backed it in and ran it in and out of gear a bit. (still wouldnt have found a heating issue though)
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top